【WordPress】自動的にプラグインの脆弱性をチェックVulnerable Plugin Checker

vulnerable_plugin_checker
Vulnerable Plugin Checkerは自動的にWPScanのAPIを利用し、インストールされたプラグインの脆弱性をチェックしてくれるプラグイン。
一日二回、新しいセキュリティ更新を確認し、任意の電子メールにアラートを提供してくれるようです。

Vulnerable Plugin Checkerプラグイン導入

ダッシュボード >> プラグイン >> 新規追加 >> Vulnerable Plugin Checkerを検索
有効化にするとツールにVPC Settingsが追加されます。

VPC Settings

vulnerable_plugin_checker_1

Enable Email Alertsにチェックを入れると脆弱性が見つかった際にAlert Email Addressに入力したメールアドレスにメールアラートが届きます。

2016.06.12追記

以下のような通知が来ました。(グレーの部分は隠しています。)その後EWWW Image Optimizerはアップデートしたら大丈夫なようでした。
We have detected one or more of your plugins are vulnerable. (EWWW Image Optimizer).

Please log into your website here: http:// and update your plugins.

This message was sent automatically from “Vulnerable Plugin Checker”.

If you wish to stop recieving emails regarding vulnerabilites, you can disable them in the VPC Settings Page: http://

 
Vulnerable Plugin Checker

【WordPress】自動的にプラグインの脆弱性をチェックVulnerable Plugin Checker

  • LATEST
  • RELATED
  • POPULAR